summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-03-06 13:39:12 -0500
committerLeo Famulari <leo@famulari.name>2018-03-06 13:39:12 -0500
commit613ef763a52d7825f062eb7b58354504b64d2869 (patch)
treebee086914ed97aab1eaba25c325268e33e57c358 /gnu/packages/compression.scm
parent86990eeda2a85acd3640059c0b681f1eddbacba0 (diff)
parent8a325748fb8c3709beb2c26966a3e3c86831f95e (diff)
downloadpatches-613ef763a52d7825f062eb7b58354504b64d2869.tar
patches-613ef763a52d7825f062eb7b58354504b64d2869.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm45
1 files changed, 27 insertions, 18 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index f25c4bba3a..423d3989aa 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -600,6 +600,7 @@ with the sfArk algorithm.")
(uri (git-reference
(url "https://github.com/raboof/sfarkxtc.git")
(commit commit)))
+ (file-name (git-file-name name version))
(sha256
(base32
"0f5x6i46qfl6ry21s7g2p4sd4b2r1g4fb03yqi2vv4kq3saryhvj"))))
@@ -1070,21 +1071,23 @@ algorithm within the Numpy framework.")
(define-public snappy
(package
(name "snappy")
- (version "1.1.3")
+ (version "1.1.7")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/google/snappy/releases/download/"
- version "/" name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/google/snappy/archive/"
+ version ".tar.gz"))
+ (file-name (string-append "snappy-" version ".tar.gz"))
(sha256
(base32
- "1wzf8yif5ym2gj52db6v5m1pxnmn258i38x7llk9x346y2nq47ig"))))
- (build-system gnu-build-system)
+ "1m7rcdqzkys5lspj8jcsaah8w33zh28s771bw0ga2lgzfgl05yix"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
(home-page "https://github.com/google/snappy")
(synopsis "Fast compressor/decompressor")
- (description "Snappy is a compression/decompression library. It does not
+ (description "Snappy is a compression/decompression library. It does not
aim for maximum compression, or compatibility with any other compression library;
-instead, it aims for very high speeds and reasonable compression. For instance,
+instead, it aims for very high speeds and reasonable compression. For instance,
compared to the fastest mode of zlib, Snappy is an order of magnitude faster
for most inputs, but the resulting compressed files are anywhere from 20% to
100% bigger.")
@@ -1130,7 +1133,7 @@ install: libbitshuffle.so
(define-public java-snappy
(package
(name "java-snappy")
- (version "1.1.4")
+ (version "1.1.7")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/xerial/snappy-java/archive/"
@@ -1138,7 +1141,7 @@ install: libbitshuffle.so
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1w58diryma7qz7aa24yv8shf3flxcbbw8jgcn2lih14wgmww58ww"))))
+ "0q4kxz2n97czf6g5gzq0d8yz22cgiaj7wp51rzsswh3bi99bpgg5"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "snappy.jar"
@@ -1178,7 +1181,9 @@ install: libbitshuffle.so
(("NAME\\): \\$\\(SNAPPY_OBJ\\)")
"NAME): $(SNAPPY_OBJ)\n\t@mkdir -p $(@D)"))
;; Finally we can run the Makefile to build the dynamic library.
- (zero? (system* "make" "native"))))
+ ;; Use the -nocmake target to avoid a dependency on cmake,
+ ;; which in turn requires the "git_unpacked" directory.
+ (invoke "make" "native-nocmake")))
;; Once we have built the shared library, we need to place it in the
;; "build" directory so it can be added to the jar file.
(add-after 'build-jni 'copy-jni
@@ -1187,13 +1192,14 @@ install: libbitshuffle.so
"build/classes/org/xerial/snappy/native")))
(add-before 'check 'fix-failing
(lambda _
- ;; This package assumes maven build, which puts results in "target".
- ;; We put them in "build" instead, so fix that.
- (substitute* "src/test/java/org/xerial/snappy/SnappyLoaderTest.java"
- (("target/classes") "build/classes"))
- ;; FIXME: probably an error
- (substitute* "src/test/java/org/xerial/snappy/SnappyOutputStreamTest.java"
- (("91080") "91013")))))))
+ (with-directory-excursion "src/test/java/org/xerial/snappy"
+ ;; This package assumes maven build, which puts results in "target".
+ ;; We put them in "build" instead, so fix that.
+ (substitute* "SnappyLoaderTest.java"
+ (("target/classes") "build/classes"))
+ ;; This requires Hadoop, which is not in Guix yet.
+ (delete-file "SnappyHadoopCompatibleOutputStreamTest.java"))
+ #t)))))
(inputs
`(("osgi-framework" ,java-osgi-framework)))
(propagated-inputs
@@ -1204,6 +1210,8 @@ install: libbitshuffle.so
("hamcrest" ,java-hamcrest-core)
("xerial-core" ,java-xerial-core)
("classworlds" ,java-plexus-classworlds)
+ ("commons-lang" ,java-commons-lang)
+ ("commons-io" ,java-commons-io)
("perl" ,perl)))
(home-page "https://github.com/xerial/snappy-java")
(synopsis "Compression/decompression algorithm in Java")
@@ -1533,6 +1541,7 @@ or junctions, and always follows hard links.")
(origin (method url-fetch)
(uri (string-append "http://github.com/twogood/unshield/archive/"
version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"0x7ps644yp5dka2zhb8w0ifqmw3d255jafpzfwv8xbcpgq6fmm2x"))))