summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 02:33:14 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:02:09 -0400
commit74d29bedc1a6b91a98d7a8f5f67ef95e8cce0c56 (patch)
tree919c81fd8424a34e05db96e5472544e355e7513b /gnu/packages/compression.scm
parent0a4d9eb770151616901736ef7a23291fde5f86d6 (diff)
downloadpatches-74d29bedc1a6b91a98d7a8f5f67ef95e8cce0c56.tar
patches-74d29bedc1a6b91a98d7a8f5f67ef95e8cce0c56.tar.gz
gnu: java-snappy-1: Use invoke.
* gnu/packages/compression.scm (java-snappy-1)[arguments]: Use invoke.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index a0d5099016..a613957434 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1173,7 +1173,7 @@ install: libbitshuffle.so
(add-before 'build 'build-jni
(lambda _
;; Rebuild one of the binaries we removed earlier
- (system* "javac" "src/main/java/org/xerial/snappy/OSInfo.java"
+ (invoke "javac" "src/main/java/org/xerial/snappy/OSInfo.java"
"-d" "lib")
;; Link to the dynamic bitshuffle and snappy, not the static ones
(substitute* "Makefile.common"
@@ -1260,7 +1260,7 @@ compresser/decompresser.")
(add-before 'build 'build-jni
(lambda _
;; Rebuild one of the binaries we removed earlier
- (system* "javac" "src/main/java/org/xerial/snappy/OSInfo.java"
+ (invoke "javac" "src/main/java/org/xerial/snappy/OSInfo.java"
"-d" "lib")
;; Link to the dynamic snappy, not the static ones
(substitute* "Makefile.common"
@@ -1277,7 +1277,7 @@ compresser/decompresser.")
(("NAME\\): \\$\\(SNAPPY_OBJ\\)")
"NAME): $(SNAPPY_OBJ)\n\t@mkdir -p $(@D)"))
;; Finally we can run the Makefile to build the dynamic library.
- (zero? (system* "make" "native"))))
+ (invoke "make" "native")))
;; Once we have built the shared library, we need to place it in the
;; "build" directory so it can be added to the jar file.
(add-after 'build-jni 'copy-jni