summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-10-22 20:17:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2015-10-23 08:57:04 +0300
commit21b2ec4d3a17e7b7077cef45df5f0e92cbf7002c (patch)
tree29dae7a84cb3ba741f48e34c0b380ec35f2b9077 /gnu/packages/compression.scm
parentc595cd47d8d60688f8eb56f25baab2854880e43c (diff)
downloadpatches-21b2ec4d3a17e7b7077cef45df5f0e92cbf7002c.tar
patches-21b2ec4d3a17e7b7077cef45df5f0e92cbf7002c.tar.gz
gnu: pbzip2: Various fixes.
* gnu/packages/compression.scm (pbzip)[uri]: Replace hardcoded version with variable. [arguments]: Remove configure phase. Add make flag.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 0bb3919cee..a9e942efd5 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -26,6 +26,7 @@
(define-module (gnu packages compression)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -232,8 +233,9 @@ decompression.")
(version "1.1.12")
(source (origin
(method url-fetch)
- (uri (string-append "https://launchpad.net/pbzip2/1.1/" version
- "/+download/" name "-" version ".tar.gz"))
+ (uri (string-append "https://launchpad.net/pbzip2/"
+ (version-major+minor version) "/" version
+ "/+download/" name "-" version ".tar.gz"))
(sha256
(base32
"1vk6065dv3a47p86vmp8hv3n1ygd9hraz0gq89gvzlx7lmcb6fsp"))))
@@ -243,20 +245,17 @@ decompression.")
(arguments
`(#:tests? #f ; no tests
#:phases (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("/usr") (assoc-ref outputs "out")))
- #t)))))
+ (delete 'configure))
+ #:make-flags (list (string-append "PREFIX=" %output))))
(home-page "http://compression.ca/pbzip2/")
(synopsis "Parallel bzip2 implementation")
(description
"Pbzip2 is a parallel implementation of the bzip2 block-sorting file
compressor that uses pthreads and achieves near-linear speedup on SMP machines.
-The output of this version is fully compatible with bzip2 v1.0.2 (ie: anything
+The output of this version is fully compatible with bzip2 v1.0.2 (i.e. anything
compressed with pbzip2 can be decompressed with bzip2).")
(license (license:non-copyleft "file://COPYING"
- "See COPYING in the distribution."))))
+ "See COPYING in the distribution."))))
(define-public xz
(package