summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-03 17:08:02 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2018-11-24 08:18:31 +0100
commitf4bf64138c9628114173e999f080c4fad3fec975 (patch)
treebb8735b5a943b40d870532540a737c5adec87931 /gnu/packages/commencement.scm
parent3d3daf7fa1794c64914ed53e51838a41d9b7adc4 (diff)
downloadpatches-f4bf64138c9628114173e999f080c4fad3fec975.tar
patches-f4bf64138c9628114173e999f080c4fad3fec975.tar.gz
gnu: Remove gcc-for-libstdc++.
* gnu/packages/commencement.scm (gcc-for-libstdc++): Remove variable. (libstdc++-boot0): Inherit GCC-4.9 instead.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 3d3f8e6650..015211f493 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1620,25 +1620,12 @@ exec " gcc "/bin/" program
,cf)))))
(inputs (%boot0-inputs)))))
-;; Use a "fixed" package source for this early libstdc++ variant so we can
-;; update GCC 4.9 without triggering a full rebuild.
-(define gcc-for-libstdc++
- (package
- (inherit gcc-4.9)
- (source (origin
- (inherit (package-source gcc-4.9))
- (patches (search-patches "gcc-4.9-libsanitizer-fix.patch"
- "gcc-arm-bug-71399.patch"
- "gcc-asan-missing-include.patch"
- "gcc-libvtv-runpath.patch"
- "gcc-fix-texi2pod.patch"))))))
-
(define libstdc++-boot0
;; GCC's libcc1 is always built as a shared library (the top-level
;; 'Makefile.def' forcefully adds --enable-shared) and thus needs to refer
;; to libstdc++.so. We cannot build libstdc++-5.3 because it relies on
;; C++14 features missing in some of our bootstrap compilers.
- (let ((lib (package-with-bootstrap-guile (make-libstdc++ gcc-for-libstdc++))))
+ (let ((lib (package-with-bootstrap-guile (make-libstdc++ gcc-4.9))))
(package
(inherit lib)
(name "libstdc++-boot0")