summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-29 06:14:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-29 06:14:11 +0200
commitff647c3d382dff13f6f43f817520053178671549 (patch)
tree14341b7e491fa12d88b760b5434f17d6f7438492 /gnu/packages/commencement.scm
parent4953c33316409945f30c4a3c33aa106ec3d84afd (diff)
downloadpatches-ff647c3d382dff13f6f43f817520053178671549.tar
patches-ff647c3d382dff13f6f43f817520053178671549.tar.gz
gnu: glibc: Move i686 patch to source field.
This is a rewrite of changes introduced by commits b2fd8f63679aa4f244c36fdca62f23c00b8eded9, c2e4f14ac8cd3e1ce7f46a192ad0c9acc084b210, 441e99d433583fdf76910c3f9323f78a1d1bbaf3 and d03b34cf190b5790ee1884ae551634f5f736f4f1. * gnu/packages/base.scm (glibc/linux)[source]: Add i686 patch. [arguments]: Remove conditional patch application from build phase. [native-inputs]: Remove patch. (glibc/hurd)[arguments]: Inherit pre-configure build phase from glibc/linux. * gnu/packages/commencement.scm (glibc-final-with-bootstrap-bash)[native-inputs]: Remove patch.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 93fec0c010..4f39a3fc66 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -510,14 +510,7 @@ the bootstrap environment."
(propagated-inputs `(("kernel-headers" ,(kernel-headers-boot0))))
(native-inputs
`(("texinfo" ,texinfo-boot0)
- ("perl" ,perl-boot0)
- ;; Apply this patch only on i686 to avoid a full rebuild.
- ;; TODO: Remove in the next update cycle.
- ,@(if (string-prefix? "i686" (or (%current-target-system)
- (%current-system)))
- `(("glibc-memchr-overflow-i686.patch"
- ,(search-patch "glibc-memchr-overflow-i686.patch")))
- '())))
+ ("perl" ,perl-boot0)))
(inputs
`(;; The boot inputs. That includes the bootstrap libc. We don't want
;; it in $CPATH, hence the 'pre-configure' phase above.