summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 06:38:04 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 06:38:54 +0100
commit3dd14ea73cb00280b9ca5d5ea32f25651c52b8db (patch)
treece7ad44b06cb36074fd7d34ccfe183236c78fc6b /gnu/packages/code.scm
parent66c2df9ee8d4540bdf370c46cb033079fb4af5df (diff)
downloadpatches-3dd14ea73cb00280b9ca5d5ea32f25651c52b8db.tar
patches-3dd14ea73cb00280b9ca5d5ea32f25651c52b8db.tar.gz
gnu: withershins: Don't use unstable tarball.
* gnu/packages/code.scm (withershins)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 62bca01221..f0943c6990 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -320,15 +320,15 @@ features that are not supported by the standard @code{stdio} implementation.")
(package
(name "withershins")
(version "0.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/cameronwhite/withershins/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "08z3lyvswx7sad10637vfpwglbcbgzzcpfihw0x8lzr74f3b70bh"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cameronwhite/withershins.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cviqvbbcwljm1zx12j6511hazr3kscwrvcyifrkfi4fpy5z985m"))))
(build-system cmake-build-system)
(arguments
`(#:out-of-source? #f