summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-13 16:19:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-15 22:19:39 +0100
commitf38607536e10f8991bf67d4f6dc5e0632f206f47 (patch)
treeafc0f26bdbd9b67a7ca5bcdef7872e4f9a0dac2a /gnu/packages/code.scm
parent618e4bfbad0740c4addc9e88d9667d5dc65b0bce (diff)
downloadpatches-f38607536e10f8991bf67d4f6dc5e0632f206f47.tar
patches-f38607536e10f8991bf67d4f6dc5e0632f206f47.tar.gz
gnu: Use INSTALL-FILE where appropriate.
* gnu/packages/admin.scm (wpa-supplicant-minimal): Substitute the simpler INSTALL-FILE for COPY-FILE when invoked with redundant arguments. * gnu/packages/bioinformatics.scm (couger, aragorn, express-beta-diversity, edirect, fasttree, rsem, samtools-0.1): Likewise. * gnu/packages/code.scm (withershins): Likewise. * gnu/packages/conky.scm (conky): Likewise. * gnu/packages/debug.scm (delta, american-fuzzy-lop): Likewise. * gnu/packages/emacs.scm (emacs-mit-scheme-doc): Likewise. * gnu/packages/engineering.scm (librecad): Likewise.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index f91fdab153..3aaa754c09 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -271,13 +271,13 @@ features that are not supported by the standard @code{stdio} implementation.")
(replace
'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/lib"))
- (mkdir (string-append out "/include"))
- (copy-file "src/withershins.hpp"
- (string-append out "/include/withershins.hpp"))
- (copy-file "src/libwithershins.a"
- (string-append out "/lib/libwithershins.a")))
+ (let* ((out (assoc-ref outputs "out"))
+ (include (string-append out "/include"))
+ (lib (string-append out "/lib")))
+ (mkdir-p include)
+ (install-file "src/withershins.hpp" include)
+ (mkdir-p lib)
+ (install-file "src/libwithershins.a" lib))
#t)))))
(home-page "https://github.com/cameronwhite/withershins")
(inputs