aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cluster.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-11 23:21:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-11 23:21:27 +0100
commit9b601fc2110193435e61955c04499fed019aac62 (patch)
tree37cca3a505989485fcfb653ebcb0dd8ee55d5308 /gnu/packages/cluster.scm
parent939c5b2cb6952cd8549bf17d6fd3bcbfb582f0bd (diff)
parent27664ea0f08e6c207b7b61c1fd7b8446dce98478 (diff)
downloadpatches-9b601fc2110193435e61955c04499fed019aac62.tar
patches-9b601fc2110193435e61955c04499fed019aac62.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/cluster.scm')
-rw-r--r--gnu/packages/cluster.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index 9548352d12..03700b0bcb 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -26,6 +26,7 @@
#:use-module (guix packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages sphinx)
@@ -87,7 +88,7 @@ independently or together to provide resilient infrastructures.")
(define-public libraft
(package
(name "libraft")
- (version "0.9.5")
+ (version "0.9.11")
(home-page "https://github.com/canonical/raft")
(source (origin
(method git-fetch)
@@ -96,10 +97,17 @@ independently or together to provide resilient infrastructures.")
(file-name (git-file-name name version))
(sha256
(base32
- "1q49f5mmv6nr6dxhnp044xwc6jlczgh0nj0bl6718wiqh28411x0"))))
- (arguments '(#:configure-flags '("--disable-uv")))
- ;; The uv plugin tests fail, if libuv (or the example) is enabled,
- ;; because setting up the environment requires too much privileges.
+ "00rsq4z9nykmf7r5rlpv1y6bvckcmg3zv57vh1h681y5pij6cch1"))))
+ (arguments '(#:configure-flags '("--enable-uv")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "Makefile.am"
+ ((".*test_uv_append.c.*") ""))
+ #t)))))
+ (inputs
+ `(("libuv" ,libuv)))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)