summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 21:57:07 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:32 +0100
commitdab41b95fb56631fe61b9d04dba59de88c95fd7c (patch)
tree8e4626efd58102533b9a9bda95000e92a9b3c5db /gnu/packages/check.scm
parenta9d1da178e5f10d5578de8be099fc79f9554fdfd (diff)
downloadpatches-dab41b95fb56631fe61b9d04dba59de88c95fd7c.tar
patches-dab41b95fb56631fe61b9d04dba59de88c95fd7c.tar.gz
gnu: python-mock: Update to 3.0.5.
* gnu/packages/check.scm (python-mock): Update to 3.0.5. [propagated-inputs]: Remove PYTHON-PBR-MINIMAL. [native-inputs]: Remove. [arguments]: Remove #:phases. Add #:tests?.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index f6654e4e3b..a8d679cc83 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -642,26 +642,20 @@ doctest.")
(define-public python-mock
(package
(name "python-mock")
- (version "2.0.0")
+ (version "3.0.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mock" version))
(sha256
(base32
- "1flbpksir5sqrvq2z0dp8sl4bzbadg21sj4d42w3klpdfvgvcn5i"))))
+ "1hrp6j0yrx2xzylfv02qa8kph661m6yq4p0mc8fnimch9j4psrc3"))))
(propagated-inputs
- `(("python-pbr" ,python-pbr-minimal)
- ("python-six" ,python-six)))
+ `(("python-six" ,python-six)))
(build-system python-build-system)
- (native-inputs
- `(("python-unittest2" ,python-unittest2)))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (zero? (system* "unit2")))))))
+ ;; FIXME: Tests require "pytest", which depends on this package.
+ '(#:tests? #f))
(home-page "https://github.com/testing-cabal/mock")
(synopsis "Python mocking and patching library for testing")
(description