summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-03 09:24:34 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-15 22:02:55 +0100
commitfedce7b2b474251a7b7e0e4fb7cc80d89a2939bd (patch)
tree2fb489a5555c73e9bcff7111bc4ca17a745e0a19 /gnu/packages/check.scm
parenta33eac038a811603c8b9ed106ae405a5f80a0e9d (diff)
downloadpatches-fedce7b2b474251a7b7e0e4fb7cc80d89a2939bd.tar
patches-fedce7b2b474251a7b7e0e4fb7cc80d89a2939bd.tar.gz
gnu: libfaketime: Fix build with glibc 2.31.
* gnu/packages/check.scm (libfaketime)[arguments]: Disable "deprecated-declarations" warnings before running the test suite.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6c809c7d7c..e819ca72cd 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2437,6 +2437,10 @@ portable to just about any platform.")
(lambda _
(substitute* "test/functests/test_exclude_mono.sh"
(("/bin/bash") (which "bash")))
+
+ ;; Do not fail due to use of 'ftime', which was deprecated in
+ ;; glibc 2.31. Remove this for later versions of libfaketime.
+ (setenv "FAKETIME_COMPILE_CFLAGS" "-Wno-deprecated-declarations")
#t)))
#:test-target "test"))
(native-inputs