summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-10 17:24:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-18 15:08:35 +0200
commit911c42de40149013ec4d1d8cc3f4b49724195937 (patch)
treebe732ae117d56692b0462ca1b645caebcab097ef /gnu/packages/check.scm
parent0963e3e450e85e3cf59b92fd28c771e8cbaaee2a (diff)
downloadpatches-911c42de40149013ec4d1d8cc3f4b49724195937.tar
patches-911c42de40149013ec4d1d8cc3f4b49724195937.tar.gz
gnu: cunit: Use ‘modify-phases’ syntax.
* gnu/packages/check.scm (cunit)[arguments]: Use ‘modify-phases’.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4b59ac567d..365cc5782e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -74,11 +74,10 @@ source code editors and IDEs.")
"057j82da9vv4li4z5ri3227ybd18nzyq81f6gsvhifs5z0vr3cpm"))))
(build-system gnu-build-system)
(arguments '(#:phases
- (alist-cons-before
- 'configure 'autoconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'autoconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)