summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-20 21:11:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-20 22:38:15 +0200
commitfa44d3a63e173a65836763ad8aa9ad447dcfc21f (patch)
treea58c4d994c3800cefa673761f8ed60c251a5a993 /gnu/packages/check.scm
parent28bcf809022056875986171adc4134f31a59ab16 (diff)
downloadpatches-fa44d3a63e173a65836763ad8aa9ad447dcfc21f.tar
patches-fa44d3a63e173a65836763ad8aa9ad447dcfc21f.tar.gz
gnu: cppcheck: Use 'git-fetch'.
* gnu/packages/check.scm (cppcheck)[source]: Use 'git-fetch'.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 684dddcb07..efedcb8743 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -298,12 +298,13 @@ format.")
(name "cppcheck")
(version "1.85")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/danmar/cppcheck/archive/"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danmar/cppcheck")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "18qlddf1i9bk5nnvy1v2nfxjd46y8wvp3rqz2hrfxjxsyvrfq5yw"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (base32 "1mk2zxypx7lq34y4i0xxgwqg6prhdzldzqmlzzr5j4safpsjynrs"))))
(build-system cmake-build-system)
(home-page "http://cppcheck.sourceforge.net")
(synopsis "Static C/C++ code analyzer")