summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-11 20:33:44 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-11 20:33:44 +0200
commit878a6baa4c705f4d551b60c5aa254246e0abc922 (patch)
tree828394061b011f0500753f85db5e2625b569cf0a /gnu/packages/check.scm
parent1c65b0e9d5731c5bcda77482ed06576f2fbfeac4 (diff)
parent7a05fdd0e1d5e5e26e94014d87bf85575bbec780 (diff)
downloadpatches-878a6baa4c705f4d551b60c5aa254246e0abc922.tar
patches-878a6baa4c705f4d551b60c5aa254246e0abc922.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index dae2b0e1d9..085538b2de 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2062,18 +2062,17 @@ create data based on random numbers and yet remain repeatable.")
(define-public python-freezegun
(package
(name "python-freezegun")
- (version "0.3.11")
+ (version "0.3.12")
(source
(origin
(method url-fetch)
(uri (pypi-uri "freezegun" version))
(sha256
- (base32 "1nh0fzqjwg88n57k3qa8mxnmiwrr7lqyd5xvc96qn5g8zcxv8fg8"))))
+ (base32 "1rx57v8ryjncjimg8hys9kx1r3rknvwcl4y340g20jn0sf69qk9a"))))
(build-system python-build-system)
(native-inputs
`(("python-mock" ,python-mock)
- ("python-nose" ,python-nose)
- ("python-coverage" ,python-coverage)))
+ ("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-six" ,python-six)
("python-dateutil" ,python-dateutil)))
@@ -2084,7 +2083,7 @@ create data based on random numbers and yet remain repeatable.")
;; package does not include the Makefile.
(replace 'check
(lambda _
- (invoke "nosetests" "./tests/"))))))
+ (invoke "pytest" "-vv"))))))
(home-page "https://github.com/spulec/freezegun")
(synopsis "Test utility for mocking the datetime module")
(description