summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-01-31 13:42:01 +0000
committerChristopher Baines <mail@cbaines.net>2018-02-01 20:21:22 +0000
commitbee301254996a84e29923e1af3fe652151e9d513 (patch)
treee9940b4f5ddadade4f3126922ff9d37dfbbb7e0b /gnu/packages/check.scm
parente543e8c0e79799dda4970af4a24260de259e222a (diff)
downloadpatches-bee301254996a84e29923e1af3fe652151e9d513.tar
patches-bee301254996a84e29923e1af3fe652151e9d513.tar.gz
gnu: Add go-github.com-smartystreets-gunit.
* gnu/packages/check.scm (go-github.com-smartystreets-gunit): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 564b75f8d1..69d5b7a382 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -308,6 +308,36 @@ normally do not detect. The goal is to detect only real errors in the code
(home-page "https://github.com/go-check/check")
(license license:bsd-2))))
+(define-public go-github.com-smartystreets-gunit
+ (package
+ (name "go-github.com-smartystreets-gunit")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/gunit")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00m4zg0kdj49mnpmf9klb44ba71p966xsk6zknrzqgfc8119f35z"))))
+ (build-system go-build-system)
+ (arguments
+ '(;; TODO: This package depends on go-github.com-smartystreets-assertions
+ ;; for running the tests, but go-github.com-smartystreets-assertions
+ ;; depends on this package, so break this loop by not running the tests
+ ;; for this package.
+ #:tests? #f
+ #:import-path "github.com/smartystreets/gunit"))
+ (synopsis "Testing tool for Go, in the style of xUnit")
+ (description
+ "@code{gunit} allows the test author to use a struct as the scope for a
+group of related test cases, in the style of xUnit fixtures. This makes
+extraction of setup/teardown behavior (as well as invoking the system under
+test) much simpler.")
+ (home-page "https://github.com/smartystreets/gunit")
+ (license license:expat)))
+
(define-public googletest
(package
(name "googletest")