summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-01-31 13:44:55 +0000
committerChristopher Baines <mail@cbaines.net>2018-02-01 20:21:25 +0000
commit8d54ace78e4bb51f0c460fff11c0b3bbc97c7e1b (patch)
treeb5c10877385e96ccfcbe3922dca14d8ca986eb03 /gnu/packages/check.scm
parentda6f9d41c15f6d9f265d60ef01293f3431651c85 (diff)
downloadpatches-8d54ace78e4bb51f0c460fff11c0b3bbc97c7e1b.tar
patches-8d54ace78e4bb51f0c460fff11c0b3bbc97c7e1b.tar.gz
gnu: Add go-github.com-smartystreets-goconvey.
* gnu/packages/check.scm (go-github.com-smartystreets-goconvey): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b26deda8a3..1276c0fda4 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages time)
@@ -363,6 +364,32 @@ for writing tests in Go.")
(home-page "https://github.com/smartystreets/assertions")
(license license:expat)))
+(define-public go-github.com-smartystreets-goconvey
+ (package
+ (name "go-github.com-smartystreets-goconvey")
+ (version "1.6.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/goconvey")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ph18rkl3ns3fgin5i4j54w5a69grrmf3apcsmnpdn1wlrbs3dxh"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/smartystreets/goconvey"))
+ (propagated-inputs
+ `(("go-github.com-jtolds-gls" ,go-github.com-jtolds-gls)
+ ("go-github.com-smartystreets-assertions" ,go-github.com-smartystreets-assertions)))
+ (synopsis "Go testing tool with both a web and terminal user interface")
+ (description
+ "GoConvey is a testing tool for Go. It integrates with go test, can show
+test coverage and has a web user interface that will refresh automatically.")
+ (home-page "https://github.com/smartystreets/goconvey")
+ (license license:expat)))
+
(define-public googletest
(package
(name "googletest")