summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-01 10:30:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-01 11:09:16 +0100
commit40899635cd5d263155cd35ff53dde9d5fa7e5a98 (patch)
treed885abda3c39484ed9c3d93ec9df5870078e4124 /gnu/packages/check.scm
parentfcaab9c0e5b339c854a895803dd3b6113e513040 (diff)
downloadpatches-40899635cd5d263155cd35ff53dde9d5fa7e5a98.tar
patches-40899635cd5d263155cd35ff53dde9d5fa7e5a98.tar.gz
gnu: python-lit: Really fix test suite.
* gnu/packages/check.scm (python-lit)[arguments]: In CHECK-PHASE, use lit to test itself, as described in README.txt. [native-inputs]: Remove PYTHON-PYTEST. Add LLVM.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 76e356ec88..f8d71ff797 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages llvm)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages time)
@@ -1177,9 +1178,9 @@ seamlessly into your existing Python unit testing work flow.")
(modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "py.test"))))))
+ (invoke "python" "lit.py" "tests"))))))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("llvm" ,llvm)))
(home-page "https://llvm.org/")
(synopsis "LLVM Software Testing Tool")
(description "@code{lit} is a portable tool for executing LLVM and Clang