summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-03 22:46:07 -0500
committerMark H Weaver <mhw@netris.org>2018-02-03 22:46:07 -0500
commite7ca634912db59596f67dc805d7b3604c5312eeb (patch)
tree567336ae23d1c566150ac39ca7673bd00a7e461f /gnu/packages/check.scm
parentb0881e0b55bf15d8111625607eb92968b65979ff (diff)
parent0903a51769427b0dac0ea515db4c5b678ce9a02c (diff)
downloadpatches-e7ca634912db59596f67dc805d7b3604c5312eeb.tar
patches-e7ca634912db59596f67dc805d7b3604c5312eeb.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm82
1 files changed, 82 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index dd54bca7e1..1e2eabeba5 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages time)
@@ -295,6 +296,87 @@ normally do not detect. The goal is to detect only real errors in the code
(home-page "https://github.com/go-check/check")
(license license:bsd-2))))
+(define-public go-github.com-smartystreets-gunit
+ (package
+ (name "go-github.com-smartystreets-gunit")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/gunit")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00m4zg0kdj49mnpmf9klb44ba71p966xsk6zknrzqgfc8119f35z"))))
+ (build-system go-build-system)
+ (arguments
+ '(;; TODO: This package depends on go-github.com-smartystreets-assertions
+ ;; for running the tests, but go-github.com-smartystreets-assertions
+ ;; depends on this package, so break this loop by not running the tests
+ ;; for this package.
+ #:tests? #f
+ #:import-path "github.com/smartystreets/gunit"))
+ (synopsis "Testing tool for Go, in the style of xUnit")
+ (description
+ "@code{gunit} allows the test author to use a struct as the scope for a
+group of related test cases, in the style of xUnit fixtures. This makes
+extraction of setup/teardown behavior (as well as invoking the system under
+test) much simpler.")
+ (home-page "https://github.com/smartystreets/gunit")
+ (license license:expat)))
+
+(define-public go-github.com-smartystreets-assertions
+ (package
+ (name "go-github.com-smartystreets-assertions")
+ (version "1.8.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/assertions")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j0adgbykl55rf2945g0n5bmqdsnjcqlx5dcmpfh4chki43hiwg9"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/smartystreets/assertions"))
+ (native-inputs
+ `(("go-github.com-smartystreets-gunit" ,go-github.com-smartystreets-gunit)))
+ (synopsis "Assertions for testing with Go")
+ (description
+ "The @code{assertions} package provides convinient assertion functions
+for writing tests in Go.")
+ (home-page "https://github.com/smartystreets/assertions")
+ (license license:expat)))
+
+(define-public go-github.com-smartystreets-goconvey
+ (package
+ (name "go-github.com-smartystreets-goconvey")
+ (version "1.6.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/goconvey")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ph18rkl3ns3fgin5i4j54w5a69grrmf3apcsmnpdn1wlrbs3dxh"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/smartystreets/goconvey"))
+ (propagated-inputs
+ `(("go-github.com-jtolds-gls" ,go-github.com-jtolds-gls)
+ ("go-github.com-smartystreets-assertions" ,go-github.com-smartystreets-assertions)))
+ (synopsis "Go testing tool with both a web and terminal user interface")
+ (description
+ "GoConvey is a testing tool for Go. It integrates with go test, can show
+test coverage and has a web user interface that will refresh automatically.")
+ (home-page "https://github.com/smartystreets/goconvey")
+ (license license:expat)))
+
(define-public googletest
(package
(name "googletest")