summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-03-02 14:42:16 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-02 15:17:56 +0100
commitdd6e70f920f7d472bbd4a66a2a2500c885ef7151 (patch)
treed4b33de99cc30c92bba5659bc13683de85c3e5ec /gnu/packages/check.scm
parent442a6ff5eae094f1fd4e09241a2f35c33ab908da (diff)
downloadpatches-dd6e70f920f7d472bbd4a66a2a2500c885ef7151.tar
patches-dd6e70f920f7d472bbd4a66a2a2500c885ef7151.tar.gz
gnu: Add cppcheck.
* gnu/packages/check.scm (cppcheck): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 21ecd8413a..c612a2a4fc 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -172,3 +173,24 @@ different compilers. Cmocka supports several different message output formats
like Test Anything Protocol, Subunit, xUnit XML or the original cmockery output
format.")
(license asl2.0)))
+
+(define-public cppcheck
+ (package
+ (name "cppcheck")
+ (version "1.72")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/danmar/cppcheck/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0zxaixhqi4vmj7xj56gzadggcbjhbjjm6abyr86qlan23sg98667"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system cmake-build-system)
+ (home-page "http://cppcheck.sourceforge.net")
+ (synopsis "Static C/C++ code analyzer")
+ (description "Cppcheck is a static code analyzer for C and C++. Unlike
+C/C++ compilers and many other analysis tools it does not detect syntax errors
+in the code. Cppcheck primarily detects the types of bugs that the compilers
+normally do not detect. The goal is to detect only real errors in the code
+(i.e. have zero false positives).")
+ (license gpl3+)))