summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-29 23:23:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-29 23:23:59 +0200
commit6e1f8d552b73e508bba47dedb5676ce5ccdcc398 (patch)
tree952a8fa2652ad26946100707311824b8c7a88768 /gnu/packages/check.scm
parentc24b896365ebf0c783140e53e000305e682d18c5 (diff)
parent8e92d5465fc154fed5d06f7e4a64d7dcccded74d (diff)
downloadpatches-6e1f8d552b73e508bba47dedb5676ce5ccdcc398.tar
patches-6e1f8d552b73e508bba47dedb5676ce5ccdcc398.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4bb608bd8f..36ecad03e2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -478,22 +478,19 @@ test coverage and has a web user interface that will refresh automatically.")
(home-page "https://github.com/smartystreets/goconvey")
(license license:expat)))
-;; XXX When updating, check whether ZNC's GOOGLETEST-SOURCES can be
-;; switched back to simply using (PACKAGE-SOURCE ...).
(define-public googletest
(package
(name "googletest")
- (version "1.8.0")
+ (version "1.8.1")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/google/googletest.git")
- (commit (string-append "release-" version))))
+ (url "https://github.com/google/googletest.git")
+ (commit (string-append "release-" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "0bjlljmbf8glnd9qjabx73w6pd7ibv43yiyngqvmvgxsabzr8399"))))
+ (base32 "0270msj6n7mggh4xqqjp54kswbl7mkcc8px1p5dqdpmw5ngh9fzk"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))