summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-13 23:04:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-13 23:04:06 +0200
commit378ebc048c033744b4f1dc13e16f4f2277d7529f (patch)
tree8411f2a9348d47858b2aca849377e91ea7f90833 /gnu/packages/check.scm
parentd99e7ee0f2bbe4abe08552afaa9821036da2a760 (diff)
parent64855281c18bab87a61c77a18c9001e6e222fb08 (diff)
downloadpatches-378ebc048c033744b4f1dc13e16f4f2277d7529f.tar
patches-378ebc048c033744b4f1dc13e16f4f2277d7529f.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 18af697693..5ecf0c1ba1 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -354,6 +354,25 @@ a CxxTest testing library, it employs no advanced features of C++ (e.g. RTTI)
and it supports a very flexible form of test discovery.")
(license license:lgpl3+)))
+(define-public doctest
+ (package
+ (name "doctest")
+ (version "2.3.5")
+ (home-page "https://github.com/onqtam/doctest")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rddlzhnv0f5036q0m0p019pismka7sx6x8cnzk65sk77b1dsbhg"))))
+ (build-system cmake-build-system)
+ (synopsis "C++ test framework")
+ (description
+ "doctest is a single-header testing framework for C++11 and later. It
+has been designed to be fast, light and unintrusive.")
+ (license license:expat)))
+
(define-public go-gopkg.in-check.v1
(let ((commit "788fd78401277ebd861206a03c884797c6ec5541")
(revision "1"))
@@ -816,6 +835,22 @@ supports coverage of subprocesses.")
(define-public python2-pytest-runner
(package-with-python2 python-pytest-runner))
+;; python-bleach 3.1.0 requires this ancient version of pytest-runner.
+;; Remove once no longer needed.
+(define-public python-pytest-runner-2
+ (package/inherit
+ python-pytest-runner
+ (version "2.12.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-runner" version))
+ (sha256
+ (base32
+ "11ivjj9hfphkv4yfb2g74av4yy86y8gcbf7gbif0p1hcdfnxg3w6"))))))
+
+(define-public python2-pytest-runner-2
+ (package-with-python2 python-pytest-runner-2))
+
(define-public python-pytest-mock
(package
(name "python-pytest-mock")