summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-27 23:33:48 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-27 23:33:48 +0200
commit5cc1075a76392666d3d733837f5c6252b1e48002 (patch)
treeaff2a303881a6fe53021a6e78a767958e608719b /gnu/packages/check.scm
parent9c2563a80b6f1d8fb8677f5314e6180ea9916aa5 (diff)
parentc30d117822a8ca26cd8c06c0a3974955bef68eac (diff)
downloadpatches-5cc1075a76392666d3d733837f5c6252b1e48002.tar
patches-5cc1075a76392666d3d733837f5c6252b1e48002.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 284670af6b..2991916431 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -461,22 +461,19 @@ test coverage and has a web user interface that will refresh automatically.")
(home-page "https://github.com/smartystreets/goconvey")
(license license:expat)))
-;; XXX When updating, check whether ZNC's GOOGLETEST-SOURCES can be
-;; switched back to simply using (PACKAGE-SOURCE ...).
(define-public googletest
(package
(name "googletest")
- (version "1.8.0")
+ (version "1.8.1")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/google/googletest.git")
- (commit (string-append "release-" version))))
+ (url "https://github.com/google/googletest.git")
+ (commit (string-append "release-" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "0bjlljmbf8glnd9qjabx73w6pd7ibv43yiyngqvmvgxsabzr8399"))))
+ (base32 "0270msj6n7mggh4xqqjp54kswbl7mkcc8px1p5dqdpmw5ngh9fzk"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))