summaryrefslogtreecommitdiff
path: root/gnu/packages/certs.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 03:27:54 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 03:27:56 +0100
commit3c747a080f015c9e62d76fc9b206b8393759e27a (patch)
tree7349d8ccabfb6c0619f38fa6237141a15e14f601 /gnu/packages/certs.scm
parent280b62b0746648783ae8bbe48ee3479b1b93cca5 (diff)
downloadpatches-3c747a080f015c9e62d76fc9b206b8393759e27a.tar
patches-3c747a080f015c9e62d76fc9b206b8393759e27a.tar.gz
gnu: nss-certs: Update phase style.
* gnu/packages/certs.scm (nss-certs)[arguments]: Use MODIFY-PHASES syntax, substitute INVOKE for SYSTEM*, and end phas with #t.
Diffstat (limited to 'gnu/packages/certs.scm')
-rw-r--r--gnu/packages/certs.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 30e53e3458..2b5ea3850a 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -102,8 +102,10 @@
(srfi srfi-26)
(ice-9 regex))
#:phases
- (alist-cons-after
- 'unpack 'install
+ (modify-phases
+ (map (cut assq <> %standard-phases)
+ '(set-paths install-locale unpack))
+ (add-after 'unpack 'install
(lambda _
(let ((certsdir (string-append %output "/etc/ssl/certs/"))
(trusted-rx (make-regexp "^# openssl-trust=[a-zA-Z]"
@@ -131,10 +133,9 @@
;; "Usage error; try -help."
;; This looks like a bug in openssl-1.0.2, but we can also
;; switch into the target directory.
- (system* "c_rehash" "."))))
+ (invoke "c_rehash" "."))
+ #t))))))
- (map (cut assq <> %standard-phases)
- '(set-paths install-locale unpack)))))
(synopsis "CA certificates from Mozilla")
(description
"This package provides certificates for Certification Authorities (CA)