summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-09-09 13:47:31 +0000
committerChristopher Baines <mail@cbaines.net>2018-02-01 22:49:50 +0000
commit1d8e04e64bbc00af9e53036ea31fa5b81eda0ae4 (patch)
tree9aff9bac31cb14ac19e1d3c96a2a9de19f0229b5 /gnu/packages/cdrom.scm
parentbff6739d5ea513417bb491a61aa276c4fb7ddd43 (diff)
downloadpatches-1d8e04e64bbc00af9e53036ea31fa5b81eda0ae4.tar
patches-1d8e04e64bbc00af9e53036ea31fa5b81eda0ae4.tar.gz
gnu: Add libburn.
* gnu/packages/cdrom.scm (libburn): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 38190340f1..8e0717e189 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 John Darrington <jmd@gnu.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 ng0 <ng0@n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -694,3 +695,25 @@ distributed with CD images and are used to describe how tracks are
laid out on the image.")
(home-page "https://www.gnu.org/software/ccd2cue/")
(license gpl3+)))
+
+(define-public libburn
+ (package
+ (name "libburn")
+ (version "1.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://files.libburnia-project.org/releases/"
+ "libburn-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wbh49s3az3sfpai09z1zdgynq7wnwrk31v5589033274nmzldlx"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://dev.lovelyhq.com/libburnia/libburn")
+ (synopsis "Library for reading and writing optical discs")
+ (description
+ "Libburn is a library for reading and writing optical discs.
+Supported media are: CD-R, CD-RW, DVD-RAM, DVD+RW, DVD+R, DVD+R/DL,
+DVD-RW, DVD-R, DVD-R/DL, BD-R, and BD-RE.")
+ (license gpl2)))