summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-09-09 13:59:39 +0000
committerChristopher Baines <mail@cbaines.net>2018-02-01 22:49:54 +0000
commitdbfab26dac1f9cc5eaf66f144d06c09f8e5afa94 (patch)
treed138b45ca46f3c81263cc893bc2d5d4af6889024 /gnu/packages/cdrom.scm
parent1d8e04e64bbc00af9e53036ea31fa5b81eda0ae4 (diff)
downloadpatches-dbfab26dac1f9cc5eaf66f144d06c09f8e5afa94.tar
patches-dbfab26dac1f9cc5eaf66f144d06c09f8e5afa94.tar.gz
gnu: Add libisofs.
* gnu/packages/cdrom.scm (libisofs): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 8e0717e189..0790444c81 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -717,3 +717,32 @@ laid out on the image.")
Supported media are: CD-R, CD-RW, DVD-RAM, DVD+RW, DVD+R, DVD+R/DL,
DVD-RW, DVD-R, DVD-R/DL, BD-R, and BD-RE.")
(license gpl2)))
+
+(define-public libisofs
+ (package
+ (name "libisofs")
+ (version "1.4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://files.libburnia-project.org/releases/"
+ "libisofs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02m5g6lbmmkh2xc5xzq5zaf3ma6v31gls66aj886b3cq9qw0paql"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("zlib" ,zlib)
+ ("acl" ,acl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://dev.lovelyhq.com/libburnia/libisofs")
+ (synopsis "Library to create ISO 9660 images")
+ (description
+ "Libisofs creates ISO 9660 (also known as ECMA-119) filesystem images
+which can either be written to POSIX file objects or handed over to
+libburn for being written directly to optical media.
+It can read metadata of ISO 9660 filesystems, manipulate them, and use them
+to produce new complete filesystem images or add-on images to be appended
+to the read filesystem image.
+Supported extensions to ISO 9660 are Rock Ridge, Joliet, AAIP, zisofs.")
+ (license gpl2+)))