summaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-07 19:02:56 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-07 19:02:56 +0200
commit6bfc16d93c04f4be2ef53a5fe271d8898a02fda8 (patch)
tree432b76be9b66ef9514ab36d4e1eb22c9ee860f20 /gnu/packages/cdrom.scm
parent2ae92cbcc107165abf79d0d0d9c2e073cc63bb13 (diff)
downloadpatches-6bfc16d93c04f4be2ef53a5fe271d8898a02fda8.tar
patches-6bfc16d93c04f4be2ef53a5fe271d8898a02fda8.tar.gz
gnu: Add cdparanoia.
* gnu/packages/cdrom.scm (cdparanoia): New variable. * gnu/packages/patches/cdparanoia-fpic.patch: New file. * gnu-system.am: Add patch.
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index d6b0a846e6..f881e7ab3a 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,7 +20,7 @@
(define-module (gnu packages cdrom)
#:use-module (guix download)
#:use-module (guix packages)
- #:use-module ((guix licenses) #:select (lgpl2.1+ gpl3+))
+ #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl3+))
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages acl)
@@ -113,3 +114,31 @@ images and it writes the session results to optical media or to filesystem
objects. Vice versa xorriso is able to copy file objects out of ISO 9660
filesystems.")
(license gpl3+)))
+
+(define-public cdparanoia
+ (package
+ (name "cdparanoia")
+ (version "10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-"
+ version ".src.tgz"))
+ (sha256
+ (base32
+ "1pv4zrajm46za0f6lv162iqffih57a8ly4pc69f7y0gfyigb8p80"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("patch/fpic" ,(search-patch "cdparanoia-fpic.patch"))))
+ (arguments
+ `(#:tests? #f ; there is no check target
+ #:patches (list (assoc-ref %build-inputs "patch/fpic"))))
+ (home-page "http://www.xiph.org/paranoia/")
+ (synopsis "audio CD reading utility which includes extra data verification features")
+ (description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
+drives. The data can be saved to a file or directed to standard output
+in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
+proprietary CDROM drive makes are supported; cdparanoia can determine if the
+target drive is CDDA capable. In addition to simple reading, cdparanoia adds
+extra-robust data verification, synchronization, error handling and scratch
+reconstruction capability.")
+ (license gpl2))) ; libraries under lgpl2.1