summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-30 19:25:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:49 +0200
commit928da609b53e0fc177d9dc99d69b0cb884d021a3 (patch)
treed11558d911a6def06299eca4db3fbe5ac006055e /gnu/packages/calendar.scm
parent8ed675a77f8f3b1eeb8c67c5d3eb450d143fb3df (diff)
downloadpatches-928da609b53e0fc177d9dc99d69b0cb884d021a3.tar
patches-928da609b53e0fc177d9dc99d69b0cb884d021a3.tar.gz
gnu: Remove python-pytest@2.
* gnu/packages/python.scm (python-pytest): Update to 3.0.7. [source]: Move substitution to ... [arguments]: ... here. Incorporate phase from pytest-3.0. [native-inputs]: Add PYTHON-HYPOTHESIS. (python-pytest-3.0): Remove variable. (python2-pytest-3.0): Rename to ... (python2-pytest): ... this. [native-inputs]: Add PYTHON2-ENUM34. * gnu/packages/backup.scm (borg)[native-inputs]: Replace PYTHON-PYTEST-3.0 with PYTHON-PYTEST. * gnu/packages/calendar.scm (khal): Likewise. * gnu/packages/databases.scm (python-orator): Likewise. * gnu/packages/python.scm (python-sphinx-1.6, python-sphinx-1.5.3, python-pexpect, python-cryptography, python-pyopenssl, python-pytest-warnings, python-pytest-capturelog, python-pytest-catchlog, python-marshmallow, python-apispec, python-flasgger, python-pyjwt, python-grako, python-honcho): Likewise. * gnu/packages/web.scm (python-internetarchive): Likewise.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index f208bc0803..2e2bd33a2d 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -118,8 +118,7 @@ data units.")
"not test_printics_read_from_stdin "
"and not test_import_from_stdin"))))))))
(native-inputs
- ;; XXX Uses tmpdir_factory, introduced in pytest 2.8.
- `(("python-pytest" ,python-pytest-3.0)
+ `(("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-setuptools-scm" ,python-setuptools-scm)
;; Required for tests