summaryrefslogtreecommitdiff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-26 19:04:54 -0400
committerLeo Famulari <leo@famulari.name>2019-03-30 15:10:19 -0400
commit6e1f91d91ca594098a7e98ae17b301fc035a6234 (patch)
tree1977a702b7516841110ed54a39dfacd3ce3382e0 /gnu/packages/calendar.scm
parente23f2ff1836e982fc2289093aab0994e0c0cf2d2 (diff)
downloadpatches-6e1f91d91ca594098a7e98ae17b301fc035a6234.tar
patches-6e1f91d91ca594098a7e98ae17b301fc035a6234.tar.gz
gnu: khal: Update to 0.10.0.
* gnu/packages/calendar.scm (khal): Update to 0.10.0. [native-inputs]: Replace tzdata with tzdata-for-tests. [arguments]: Simplify the check phase.
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 226d8f57e2..90f23452f7 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -96,13 +96,13 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.9.10")
+ (version "0.10.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
(sha256
(base32
- "03h0j0d3xyqh98x5v2gv63wv3g91hip3vsaxvybsn5iz331d23h4"))))
+ "1p49f3g25x900vk32spjbr2aipj12kcbhayny2vwhdpkjlv6k396"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -122,22 +122,14 @@ data units.")
(setenv "TZ"
(string-append (assoc-ref inputs "tzdata")
"/share/zoneinfo/Zulu"))
- (invoke "py.test" "tests" "-k"
- (string-append
- ;; These tests are known to fail in when not
- ;; running in a TTY:
- ;; https://github.com/pimutils/khal/issues/683
- "not test_printics_read_from_stdin "
- "and not test_import_from_stdin "
- ;; https://github.com/pimutils/khal/issues/825
- "and not test_description_and_location_and_categories")))))))
+ (invoke "py.test" "tests"))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-setuptools-scm" ,python-setuptools-scm)
;; Required for tests
("python-freezegun" ,python-freezegun)
- ("tzdata" ,tzdata)
+ ("tzdata" ,tzdata-for-tests)
("vdirsyncer" ,vdirsyncer)
;; Required to build manpage
("python-sphinxcontrib-newsfeed" ,python-sphinxcontrib-newsfeed)