summaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-06-17 16:26:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-06-17 16:27:16 +0300
commit505459d7cb139eaa3b73b4977d502a3acc400b3b (patch)
tree6a69da6d3dc1fab761eccadb124624a90b56ca9c /gnu/packages/busybox.scm
parentde2d14f2ff3577f521b6dc9c52f45924249c1949 (diff)
downloadpatches-505459d7cb139eaa3b73b4977d502a3acc400b3b.tar
patches-505459d7cb139eaa3b73b4977d502a3acc400b3b.tar.gz
gnu: busybox: Don't install to usr.
* gnu/packages/busybox.scm (busybox)[arguments]: Add a custom phase to prevent installing to %PREFIX/usr.
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 182b8ac618..7bb677cdd0 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -54,6 +54,12 @@
#t))
(replace 'configure
(lambda _ (invoke "make" "defconfig")))
+ (add-after 'configure 'dont-install-to-usr
+ (lambda _
+ (substitute* ".config"
+ (("# CONFIG_INSTALL_NO_USR is not set")
+ "CONFIG_INSTALL_NO_USR=y"))
+ #t))
(replace 'check
(lambda _
(substitute* '("testsuite/du/du-s-works"