summaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-06-26 13:51:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-06-26 13:51:26 +0200
commita167873c67a17df8175f896750de2d905d0fae04 (patch)
treee84bd2845b5456ef67e7337f54bdb3cc2e5b7512 /gnu/packages/busybox.scm
parent7c3bea7e6299e1026c7964c83986a6b6c220879a (diff)
parent7c7323e432620a42f896056f076020a748c1fd6d (diff)
downloadpatches-a167873c67a17df8175f896750de2d905d0fae04.tar
patches-a167873c67a17df8175f896750de2d905d0fae04.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 6ef7200f9d..4cdea3a294 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,7 +45,7 @@
'(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda _ (zero? (system* "make" "defconfig"))))
+ (lambda _ (invoke "make" "defconfig")))
(replace 'check
(lambda _
(substitute* '("testsuite/du/du-s-works"
@@ -71,18 +72,17 @@
(delete-file "testsuite/which/which-uses-default-path")
(rmdir "testsuite/which")
- (zero? (system* "make"
- ;; "V=1"
- "SKIP_KNOWN_BUGS=1"
- "SKIP_INTERNET_TESTS=1"
- "check"))))
+ (invoke "make"
+ ;; "V=1"
+ "SKIP_KNOWN_BUGS=1"
+ "SKIP_INTERNET_TESTS=1"
+ "check")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (zero?
- (system* "make"
- (string-append "CONFIG_PREFIX=" out)
- "install"))))))))
+ (invoke "make"
+ (string-append "CONFIG_PREFIX=" out)
+ "install")))))))
(native-inputs `(("perl" ,perl) ; needed to generate the man pages (pod2man)
;; The following are needed by the tests.
("inetutils" ,inetutils)