summaryrefslogtreecommitdiff
path: root/gnu/packages/build-tools.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-10 15:32:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-10 15:32:51 +0200
commit7b38f045c04fe69001ff5c2f04486cc51a69ae82 (patch)
treebd839f1f635dc114c84d67c1db09b74f613ec315 /gnu/packages/build-tools.scm
parent369d15674c8bb251c45a45466031a2da1640df9f (diff)
parent256d5c6e339d59287284bb83f35c594f13bd08f9 (diff)
downloadpatches-7b38f045c04fe69001ff5c2f04486cc51a69ae82.tar
patches-7b38f045c04fe69001ff5c2f04486cc51a69ae82.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/build-tools.scm')
-rw-r--r--gnu/packages/build-tools.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 24870c82d6..4fc2d5acf7 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -25,6 +25,7 @@
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
@@ -76,16 +77,16 @@ makes a few sacrifices to acquire fast full and incremental build times.")
(define-public bear
(package
(name "bear")
- (version "2.3.11")
+ (version "2.3.12")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/rizsotto/Bear/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rizsotto/Bear")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1m0w0wqnz983l7fpp5p9pdsqr7n3ybrzp8ywjcvn0rihsrzj65j6"))))
+ "1zzz2yiiny9pm4h6ayb82xzxc2j5djcpf8va2wagcw92m7w6miqw"))))
(build-system cmake-build-system)
(inputs
`(("python" ,python-wrapper)))