summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2018-11-16 21:30:28 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2018-11-18 16:45:03 +0100
commit4fd4efc812b18c11a2ed22a13befc630f5b95434 (patch)
tree2c794da622d11c27391cb7f906a324ee8d4ac799 /gnu/packages/bootstrap.scm
parent562c37c7beaea9e6912d5ae1c7f7dc8d2a2a3a64 (diff)
downloadpatches-4fd4efc812b18c11a2ed22a13befc630f5b95434.tar
patches-4fd4efc812b18c11a2ed22a13befc630f5b95434.tar.gz
bootstrap: Replace %mescc-tools-seed with %bootstrap-mescc-tools.
* gnu/packages/bootstrap.scm (%mescc-tools-seed): Remove. (%bootstrap-inputs): Replace %mescc-tools-seed with %bootstrap-mescc-tools. * gnu/packages/commencement.scm (mes-boot): Likewise. (tcc-boot0): Likewise. (mescc-tools-boot): Remove.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 620f888eb0..93e9d8ddbd 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -51,7 +51,6 @@
%bootstrap-inputs
%bootstrap-mescc-tools
%bootstrap-mes
- %mescc-tools-seed
%srfi-43))
;;; Commentary:
@@ -713,17 +712,6 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
(home-page #f)
(license gpl3+)))
-(define %mescc-tools-seed ; todo: add tarballs to alpha.gnu.org/pub/mes/bootstrap/
- (let ((commit "dc4e20e74924a5c80a2b7a77b4d7b927234fa71c"))
- (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.com/janneke/mescc-tools-seed"
- "/-/archive/" commit
- "/mescc-tools-seed-" commit ".tar.gz"))
- (sha256
- (base32
- "1lj7df73vxanmffmiwkhcn83r7yd9n8568nkki06bqq5zg526nyz")))))
-
(define %srfi-43
(origin
(method url-fetch)
@@ -739,7 +727,7 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
`(,@(match (%current-system)
((or "i686-linux" "x86_64-linux")
`(("linux-libre-headers" ,%bootstrap-linux-libre-headers)
- ("mescc-tools-seed" ,%mescc-tools-seed)
+ ("bootstrap-mescc-tools" ,%bootstrap-mescc-tools)
("mes" ,%bootstrap-mes)
("srfi-43" ,%srfi-43 )))
(_