summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-25 02:16:25 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-25 02:17:58 +0100
commit0b07f22728488f2f85624b716e5398bbb3a4165d (patch)
treeee2d3693a042090dbcce688b7c8581c3ad7be6bb /gnu/packages/bootstrap.scm
parentdad2e7dc79112733dd5e1086ba77aa1daddb0c49 (diff)
downloadpatches-0b07f22728488f2f85624b716e5398bbb3a4165d.tar
patches-0b07f22728488f2f85624b716e5398bbb3a4165d.tar.gz
gnu: bootstrap: Add missing 'supported-systems', remove extra 'match'.
Previously evaluation would fail for armhf, aarch64, and mips64el. * gnu/packages/bootstrap.scm (%bootstrap-mescc-tools)[supported-systems]: New field. (%bootstrap-mes)[supported-systems]: New field. [inputs]: Remove 'match' form on %current-system, which would fail on non-Intel platforms.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 72e3d0847f..d9570a32f5 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -659,6 +659,7 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
(synopsis "Bootstrap binaries of MesCC Tools")
(description synopsis)
(home-page #f)
+ (supported-systems '("i686-linux" "x86_64-linux"))
(license gpl3+)))
(define %bootstrap-mes
@@ -702,10 +703,9 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
"mes-minimal-stripped-0.19-i686-linux.tar.xz")
%bootstrap-base-urls))
(sha256
- (match (%current-system)
- ((or "i686-linux" "x86_64-linux")
- (base32
- "0k7kkl68a6xaadv47ij0nr9jm5ca1ffj38n7f2lg80y72wdkwr9h")))))))))
+ (base32
+ "0k7kkl68a6xaadv47ij0nr9jm5ca1ffj38n7f2lg80y72wdkwr9h")))))))
+ (supported-systems '("i686-linux" "x86_64-linux"))
(synopsis "Bootstrap binaries of Mes")
(description synopsis)
(home-page #f)