summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-30 16:30:49 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-30 16:30:49 +0100
commita9ebd9efd0d97159acbec848ad5fe06f022c8235 (patch)
tree718f8a04ac525537ed2e297bf38bbedb68f4e8f1 /gnu/packages/bootstrap.scm
parentfd060fd30da53f2b0856f6f451f8fd7b8c760d70 (diff)
downloadpatches-a9ebd9efd0d97159acbec848ad5fe06f022c8235.tar
patches-a9ebd9efd0d97159acbec848ad5fe06f022c8235.tar.gz
store: Remove the `fixed?' parameter from `add-to-store'.
* guix/store.scm (add-to-store): Remove the `fixed?' parameter from the public interface. * gnu/packages/bootstrap.scm, guix-download.in, guix/derivations.scm, guix/packages.scm, tests/derivations.scm: Update all callers accordingly.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index b0ab70abbc..22ee98879a 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -154,7 +154,7 @@ check whether everything is alright."
(description "Raw build system with direct store access")
(build (lambda* (store name source inputs #:key outputs system)
(define (->store file)
- (add-to-store store file #t #t "sha256"
+ (add-to-store store file #t "sha256"
(or (search-bootstrap-binary file
system)
(error "bootstrap binary not found"