summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-10 23:02:33 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-10 23:02:33 +0200
commit5fbeb4e6e19856678fa78ee7878e90411d718598 (patch)
treea4cddc1e066ccc5a3166c0f34e983cc901203a46 /gnu/packages/bootstrap.scm
parent1d9bc45925ae1cb8b1984a8fc5eb439aad592c2a (diff)
downloadpatches-5fbeb4e6e19856678fa78ee7878e90411d718598.tar
patches-5fbeb4e6e19856678fa78ee7878e90411d718598.tar.gz
gnu: bootstrap: Use the bootstrap tools for <origin> patching.
* gnu/packages/bootstrap.scm (bootstrap-origin): Override the 'patch-guile' and 'patch-inputs' fields of SOURCE.
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index a1d4c7fc67..86be880cfd 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -64,11 +64,21 @@
#:guile %bootstrap-guile
#:system system)))
+ (define %bootstrap-patch-inputs
+ ;; Packages used when an <origin> has a non-empty 'patches' field.
+ `(("tar" ,%bootstrap-coreutils&co)
+ ("xz" ,%bootstrap-coreutils&co)
+ ("bzip2" ,%bootstrap-coreutils&co)
+ ("gzip" ,%bootstrap-coreutils&co)
+ ("patch" ,%bootstrap-coreutils&co)))
+
(let ((orig-method (origin-method source)))
(origin (inherit source)
(method (cond ((eq? orig-method url-fetch)
(boot url-fetch))
- (else orig-method))))))
+ (else orig-method)))
+ (patch-guile %bootstrap-guile)
+ (patch-inputs %bootstrap-patch-inputs))))
(define (package-from-tarball name* source* program-to-test description*)
"Return a package that correspond to the extraction of SOURCE*.