summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@inbox.ru>2017-02-19 19:31:58 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-07 18:20:33 +0100
commit605fec783f630b8aa92bbfeb510f716144de90d8 (patch)
treefaa40b20b1bd5384610a42abf1d9160f39ea47d7 /gnu/packages/bootstrap.scm
parentd6abd094fcffdbd5b693ba509e2de3da28c849ec (diff)
downloadpatches-605fec783f630b8aa92bbfeb510f716144de90d8.tar
patches-605fec783f630b8aa92bbfeb510f716144de90d8.tar.gz
gnu: Add basic support for "alpha-linux" systems.
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add "/lib/ld-linux.so.2" as "alpha-linux" ld.so. * gnu/packages/linux.scm (system->linux-architecture): Add "alpha" arch. Signed-off-by: Sergei Trofimovich <slyfox@inbox.ru> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index c8d94c8303..b4847094ba 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -167,6 +167,7 @@ successful, or false to signal an error."
((string=? system "i586-gnu") "/lib/ld.so.1")
((string=? system "i686-gnu") "/lib/ld.so.1")
((string=? system "aarch64-linux") "/lib/ld-linux-aarch64.so.1")
+ ((string=? system "alpha-linux") "/lib/ld-linux.so.2")
;; XXX: This one is used bare-bones, without a libc, so add a case
;; here just so we can keep going.