summaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2016-11-18 22:58:01 +0100
committerTomáš Čech <sleep_walker@gnu.org>2016-12-01 21:05:20 +0100
commit4b67098d9a69ccb176da116dadd1c28804c2c790 (patch)
tree3561e47ae13a3ca08bb149dc11ad916599a02187 /gnu/packages/bittorrent.scm
parent02ecdeaa02457fc3e5eb1f201da9dbab5598b770 (diff)
downloadpatches-4b67098d9a69ccb176da116dadd1c28804c2c790.tar
patches-4b67098d9a69ccb176da116dadd1c28804c2c790.tar.gz
gnu: Add uget.
* gnu/packages/bittorrent.scm (uget): New variable.
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index eff1b5a1c4..ce0565ea71 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Tomáš Čech <sleep_walker@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,11 +30,15 @@
#:use-module (gnu packages adns)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
#:use-module (gnu packages file)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
@@ -251,3 +256,38 @@ interface, for the Transmission BitTorrent daemon.")
download utility. It supports HTTP/HTTPS, FTP, SFTP, BitTorrent and Metalink.
Aria2 can be manipulated via built-in JSON-RPC and XML-RPC interfaces.")
(license l:gpl2+)))
+
+
+(define-public uget
+ (package
+ (name "uget")
+ (version "2.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/urlget/"
+ "uget%20%28stable%29/" version "/uget-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0919cf7lfk1djdl003cahqjvafdliv7v2l8r5wg95n4isqggdk75"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)))
+ (inputs
+ `(("curl" ,curl)
+ ("gtk+" ,gtk+)
+ ("glib" ,glib)
+ ("gnutls" ,gnutls)
+ ("gstreamer" ,gstreamer)
+ ("libgcrypt" ,libgcrypt)
+ ("libnotify" ,libnotify)
+ ("openssl" ,openssl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://ugetdm.com/")
+ (synopsis "Universal download manager with GTK+ interface")
+ (description
+ "uGet is portable download manager with GTK+ interface supporting
+HTTP, HTTPS, BitTorrent and Metalink, supporting multi-connection
+downloads, download scheduling, download rate limiting.")
+ (license l:lgpl2.1+)))