summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-03-18 15:59:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-18 16:00:30 +0100
commit19bd7f2e79737911ee03ca73521fede01fef18bd (patch)
tree45f08a2e0631d84e59733b03f9bcc5184cd2d522 /gnu/packages/bioinformatics.scm
parent0dfeb285234ef9b9ac6a01486b0edfa93310ee6d (diff)
downloadpatches-19bd7f2e79737911ee03ca73521fede01fef18bd.tar
patches-19bd7f2e79737911ee03ca73521fede01fef18bd.tar.gz
gnu: Add arriba.
* gnu/packages/bioinformatics.scm (arriba): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 498ebc38b6..b2d7277c23 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14445,3 +14445,69 @@ repeated areas between contigs.")
"Velocyto is a library for the analysis of RNA velocity. Velocyto
includes a command line tool and an analysis pipeline.")
(license license:bsd-2)))
+
+(define-public arriba
+ (package
+ (name "arriba")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/suhrig/arriba/releases/"
+ "download/v" version "/arriba_v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jx9656ry766vb8z08m1c3im87b0c82qpnjby9wz4kcz8vn87dx2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((htslib (assoc-ref inputs "htslib")))
+ (substitute* "Makefile"
+ (("-I\\$\\(HTSLIB\\)/htslib")
+ (string-append "-I" htslib "/include/htslib"))
+ ((" \\$\\(HTSLIB\\)/libhts.a")
+ (string-append " " htslib "/lib/libhts.so"))))
+ (substitute* "run_arriba.sh"
+ (("^STAR ") (string-append (which "STAR") " "))
+ (("samtools --version-only")
+ (string-append (which "samtools") " --version-only"))
+ (("samtools index")
+ (string-append (which "samtools") " index"))
+ (("samtools sort")
+ (string-append (which "samtools") " sort")))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "arriba" bin)
+ (install-file "run_arriba.sh" bin)
+ (install-file "draw_fusions.R" bin)
+ (wrap-program (string-append bin "/draw_fusions.R")
+ `("R_LIBS_SITE" ":" prefix (,(getenv "R_LIBS_SITE")))))
+ #t)))))
+ (inputs
+ `(("htslib" ,htslib)
+ ("r-minimal" ,r-minimal)
+ ("r-circlize" ,r-circlize)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("samtools" ,samtools)
+ ("star" ,star)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/suhrig/arriba")
+ (synopsis "Gene fusion detection from RNA-Seq data ")
+ (description
+ "Arriba is a command-line tool for the detection of gene fusions from
+RNA-Seq data. It was developed for the use in a clinical research setting.
+Therefore, short runtimes and high sensitivity were important design criteria.
+It is based on the fast STAR aligner and the post-alignment runtime is
+typically just around two minutes. In contrast to many other fusion detection
+tools which build on STAR, Arriba does not require to reduce the
+@code{alignIntronMax} parameter of STAR to detect small deletions.")
+ ;; All code is under the Expat license with the exception of
+ ;; "draw_fusions.R", which is under GPLv3.
+ (license (list license:expat license:gpl3))))