summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-08 21:40:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-08 21:40:51 +0200
commit4bdf4182fe080c3409f6ef9b410146b67cfa2595 (patch)
treef1123ddb8c57eda6de026982904f6c5309adaca6 /gnu/packages/bioinformatics.scm
parentc81457a5883ea43950eb2ecdcbb58a5b144bcd11 (diff)
parent23a59b180b28b9fa22120c2b8305b9324442b94d (diff)
downloadpatches-4bdf4182fe080c3409f6ef9b410146b67cfa2595.tar
patches-4bdf4182fe080c3409f6ef9b410146b67cfa2595.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 40f75e9e0c..32b795948b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11995,7 +11995,8 @@ dependency like SeqAn.")
;; Ensure that Eigen headers can be found
(setenv "CPLUS_INCLUDE_PATH"
(string-append (assoc-ref inputs "eigen")
- "/include/eigen3"))
+ "/include/eigen3:"
+ (or (getenv "CPLUS_INCLUDE_PATH") "")))
#t)))))
(inputs
`(("boost" ,boost)
@@ -12173,8 +12174,8 @@ The following file formats are supported:
(("lib/libdivsufsort.a") "/lib/libdivsufsort.so"))
;; Ensure that all headers can be found
- (setenv "CPATH"
- (string-append (getenv "CPATH")
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-append (or (getenv "CPLUS_INCLUDE_PATH") "")
":"
(assoc-ref inputs "eigen")
"/include/eigen3"))