summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 11:07:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 12:01:23 +0200
commit0d7974c376c4b84dd26096ba0c53ed2535afcbc9 (patch)
tree6e919a15fc90ff58d0553ab6f05668165191e14c /gnu/packages/bioinformatics.scm
parentca1dc4c76a81d289360c0601fed16a7852833d9b (diff)
downloadpatches-0d7974c376c4b84dd26096ba0c53ed2535afcbc9.tar
patches-0d7974c376c4b84dd26096ba0c53ed2535afcbc9.tar.gz
gnu: libbigwig: Update to 0.4.2.
* gnu/packages/bioinformatics.scm (libbigwig): Update to 0.4.2. [source]: Fetch from git. [arguments]: Disable tests; remove build phases "disable-curl-test" and "create-target-dirs". [native-inputs]: Add python-2.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 12 insertions, 21 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f60fc4c84c..7f865ae878 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1887,42 +1887,33 @@ other types of unwanted sequence from high-throughput sequencing reads.")
(define-public libbigwig
(package
(name "libbigwig")
- (version "0.1.4")
+ (version "0.4.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/dpryan79/libBigWig/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dpryan79/libBigWig.git")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "098rjh35pi4a9q83n8wiwvyzykjqj6l8q189p1xgfw4ghywdlvw1"))))
+ "0h2smg24v5srdcqzrmz2g23cmlp4va465mgx8r2z571sfz8pv454"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
+ #:tests? #f ; tests require access to the web
#:make-flags
(list "CC=gcc"
(string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (add-before 'check 'disable-curl-test
- (lambda _
- (substitute* "Makefile"
- (("./test/testRemote.*") ""))
- #t))
- ;; This has been fixed with the upstream commit 4ff6959cd8a0, but
- ;; there has not yet been a release containing this change.
- (add-before 'install 'create-target-dirs
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/lib"))
- (mkdir-p (string-append out "/include"))
- #t))))))
+ (delete 'configure))))
(inputs
`(("zlib" ,zlib)
("curl" ,curl)))
(native-inputs
- `(("doxygen" ,doxygen)))
+ `(("doxygen" ,doxygen)
+ ;; Need for tests
+ ("python" ,python-2)))
(home-page "https://github.com/dpryan79/libBigWig")
(synopsis "C library for handling bigWig files")
(description