summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-09-05 11:02:03 +0200
committerRoel Janssen <roel@gnu.org>2017-09-05 11:02:03 +0200
commit325c039c1da3f7686d8b1456427eea8fdca92d05 (patch)
tree530bec3d1dd1fb6610d6fb2ae5ab6a9031ab17eb /gnu/packages/bioinformatics.scm
parentc0ac72e18c8a53f7173e7f8b24f2e7aaf743c97e (diff)
downloadpatches-325c039c1da3f7686d8b1456427eea8fdca92d05.tar
patches-325c039c1da3f7686d8b1456427eea8fdca92d05.tar.gz
gnu: Add r-sparql.
* gnu/packages/bioinformatics.scm (r-sparql): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5e8eef4e1c..bf8eb2e697 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6137,6 +6137,29 @@ data. It is derived from the UCSC hg19 genome and based on the \"knownGene\"
track. The database is exposed as a @code{TxDb} object.")
(license license:artistic2.0)))
+(define-public r-sparql
+ (package
+ (name "r-sparql")
+ (version "1.16")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "SPARQL" version))
+ (sha256
+ (base32
+ "0gak1q06yyhdmcxb2n3v0h9gr1vqd0viqji52wpw211qp6r6dcrc"))))
+ (properties `((upstream-name . "SPARQL")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcurl" ,r-rcurl)
+ ("r-xml" ,r-xml)))
+ (home-page "http://cran.r-project.org/web/packages/SPARQL")
+ (synopsis "SPARQL client for R")
+ (description "This package provides an interface to use SPARQL to pose
+SELECT or UPDATE queries to an end-point.")
+ ;; The only license indication is found in the DESCRIPTION file,
+ ;; which states GPL-3. So we cannot assume GPLv3+.
+ (license license:gpl3)))
+
(define-public vsearch
(package
(name "vsearch")