summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-26 16:08:47 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-05-18 11:59:34 +0200
commite62ffce538649f97da702fc1080fa06668df10e7 (patch)
treece8c67054f6c78580304d6bafb506daa74e43108 /gnu/packages/bioinformatics.scm
parentdbd40ac19df16bb2ef0387c5fcbe8103b6b64840 (diff)
downloadpatches-e62ffce538649f97da702fc1080fa06668df10e7.tar
patches-e62ffce538649f97da702fc1080fa06668df10e7.tar.gz
gnu: Add Piranha.
* gnu/packages/bioinformatics.scm (piranha): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 60cf6b7007..1f7972870c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5051,6 +5051,70 @@ two-dimensional genome scans.")
libraries for systems that do not have these available via other means.")
(license license:artistic2.0)))
+(define-public piranha
+ (package
+ (name "piranha")
+ (version "1.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/smithlabcode/piranha"
+ "/archive/svn/tags/piranha-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1lczxff01n4139w7xwqamlb36g9hgrcy93gh03nqszhwb8ivsrqd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'copy-smithlab-cpp
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir "src/smithlab_cpp")
+ (for-each (lambda (file)
+ (install-file file "./src/smithlab_cpp/"))
+ (find-files (assoc-ref inputs "smithlab-cpp")))
+ #t))
+ (add-after 'install 'install-to-store
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p bin)
+ (for-each (lambda (file)
+ (install-file file bin))
+ (find-files "bin" ".*")))
+ #t)))
+ #:configure-flags
+ (list (string-append "--with-bam_tools_headers="
+ (assoc-ref %build-inputs "bamtools") "/include/bamtools")
+ (string-append "--with-bam_tools_library="
+ (assoc-ref %build-inputs "bamtools") "/lib/bamtools"))))
+ (inputs
+ `(("bamtools" ,bamtools)
+ ("samtools" ,samtools-0.1)
+ ("gsl" ,gsl)
+ ("smithlab-cpp"
+ ,(let ((commit "3723e2d"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smithlabcode/smithlab_cpp.git")
+ (commit commit)))
+ (file-name (string-append "smithlab_cpp-" commit "-checkout"))
+ (sha256
+ (base32
+ "0l4gvbwslw5ngziskja41c00x1r06l3yidv7y0xw9djibhykzy0g")))))))
+ (native-inputs
+ `(("python" ,python-2)))
+ (home-page "https://github.com/smithlabcode/piranha")
+ (synopsis "Peak-caller for CLIP-seq and RIP-seq data")
+ (description
+ "Piranha is a peak-caller for genomic data produced by CLIP-seq and
+RIP-seq experiments. It takes input in BED or BAM format and identifies
+regions of statistically significant read enrichment. Additional covariates
+may optionally be provided to further inform the peak-calling process.")
+ (license license:gpl3+)))
+
(define-public pepr
(package
(name "pepr")