summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-18 19:26:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-08-08 15:18:32 +0300
commit7d71557d4d3ca5bdd33eb8c9bdf0cd2aba624554 (patch)
treede518f924136cf2ab6951ec82d4891c4de0d0d36 /gnu/packages/bioinformatics.scm
parent70782dddffc2da05fed6aba35c3121a2265fd649 (diff)
downloadpatches-7d71557d4d3ca5bdd33eb8c9bdf0cd2aba624554.tar
patches-7d71557d4d3ca5bdd33eb8c9bdf0cd2aba624554.tar.gz
gnu: Add fastahack.
* gnu/packages/bioinformatics.scm (fastahack): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a3c83f73bb..4dae22082d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14962,3 +14962,36 @@ combinatorial configurations.\", G. Ehrlich - Journal of the ACM (JACM),
(description "A tiny C library for managing SOM (Self-Organizing Maps)
neural networks.")
(license license:gpl3))))
+
+(define-public fastahack
+ (let ((commit "c68cebb4f2e5d5d2b70cf08fbdf1944e9ab2c2dd"))
+ (package
+ (name "fastahack")
+ (version (git-version "0.0.0" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ekg/fastahack/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hfdv67l9g611i2ck4l92pd6ygmsp9g1ph4zx1ni7qkpsikf0l19"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; Unclear how to run tests: https://github.com/ekg/fastahack/issues/15
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "fastahack" bin))
+ #t)))))
+ (home-page "https://github.com/ekg/fastahack")
+ (synopsis "Indexing and sequence extraction from FASTA files")
+ (description "Fastahack is a small application for indexing and
+extracting sequences and subsequences from FASTA files. The included library
+provides a FASTA reader and indexer that can be embedded into applications
+which would benefit from directly reading subsequences from FASTA files. The
+library automatically handles index file generation and use.")
+ (license (list license:expat license:gpl2)))))