summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-08-09 19:40:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-14 12:00:56 +0200
commit9634804890a811f65267f273835b001cc087c23f (patch)
tree80fa3471f067fae2c4ab71f9d1a0a959c995e120 /gnu/packages/bioinformatics.scm
parent86763fdd70b48df5e4be5f2df6ac4335d9f7abe5 (diff)
downloadpatches-9634804890a811f65267f273835b001cc087c23f.tar
patches-9634804890a811f65267f273835b001cc087c23f.tar.gz
gnu: Add bismark.
* gnu/packages/bioinformatics.scm (bismark): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c5a4dcad93..9d64294e48 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9797,3 +9797,66 @@ such as transcription factor binding sites (ChIP-seq) or regions of open
chromatin (DNase-seq). Output can be displayed directly in the UCSC Genome
Browser.")
(license license:gpl3+))))
+
+(define-public bismark
+ (package
+ (name "bismark")
+ (version "0.16.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/FelixKrueger/Bismark/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1204i0pa02ll2jn5pnxypkclnskvv7a2nwh5nxhagmhxk9wfv9sq"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin"))
+ (docdir (string-append (assoc-ref outputs "out")
+ "/share/doc/bismark"))
+ (docs '("Bismark_User_Guide.pdf"
+ "RELEASE_NOTES.txt"))
+ (scripts '("bismark"
+ "bismark_genome_preparation"
+ "bismark_methylation_extractor"
+ "bismark2bedGraph"
+ "bismark2report"
+ "coverage2cytosine"
+ "deduplicate_bismark"
+ "bismark_sitrep.tpl"
+ "bam2nuc"
+ "bismark2summary")))
+ (mkdir-p docdir)
+ (mkdir-p bin)
+ (for-each (lambda (file) (install-file file bin))
+ scripts)
+ (for-each (lambda (file) (install-file file docdir))
+ docs)
+ #t))))))
+ (home-page "http://www.bioinformatics.babraham.ac.uk/projects/bismark/")
+ (synopsis "Map bisulfite treated sequence reads and analyze methylation")
+ (description "Bismark is a program to map bisulfite treated sequencing
+reads to a genome of interest and perform methylation calls in a single step.
+The output can be easily imported into a genome viewer, such as SeqMonk, and
+enables a researcher to analyse the methylation levels of their samples
+straight away. Its main features are:
+
+@itemize
+@item Bisulfite mapping and methylation calling in one single step
+@item Supports single-end and paired-end read alignments
+@item Supports ungapped and gapped alignments
+@item Alignment seed length, number of mismatches etc are adjustable
+@item Output discriminates between cytosine methylation in CpG, CHG
+ and CHH context
+@end itemize\n")
+ (license license:gpl3+)))