summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-06-17 14:39:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-17 20:22:38 +0200
commita6f2ced34b873612e6caca719ed448af3ee92b7e (patch)
tree3ce6d32d4e6f37fc12ded98c1464f7ecbd6d2b1e /gnu/packages/bioinformatics.scm
parentbf473f0ca0b218e9a93b00234a8f25ba015b8bd3 (diff)
downloadpatches-a6f2ced34b873612e6caca719ed448af3ee92b7e.tar
patches-a6f2ced34b873612e6caca719ed448af3ee92b7e.tar.gz
gnu: Add tbsp.
* gnu/packages/bioinformatics.scm (tbsp): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 90f12f41ec..8002f24110 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14756,3 +14756,40 @@ spliced-in} (PSI) values of alternatively-spliced exons that were computed by
vast-tools, an RNA-Seq pipeline for alternative splicing analysis. The plots
are generated using @code{ggplot2}.")
(license license:expat)))
+
+(define-public tbsp
+ (let ((commit "ec8fff4410cfb13a677dbbb95cbbc60217e64907")
+ (revision "1"))
+ (package
+ (name "tbsp")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phoenixding/tbsp.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "025ym14x8gbd6hb55lsinqj6f5qzw36i10klgs7ldzxxd7s39ki1"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; no tests included
+ (inputs
+ `(("python-matplotlib" ,python-matplotlib)
+ ("python-networkx" ,python-networkx)
+ ("python-numpy" ,python-numpy)
+ ("python-pybigwig" ,python-pybigwig)
+ ("python-biopython" ,python-biopython)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-scipy" ,python-scipy)))
+ (home-page "https://github.com/phoenixding/tbsp/")
+ (synopsis "SNP-based trajectory inference")
+ (description
+ "Several studies focus on the inference of developmental and response
+trajectories from single cell RNA-Seq (scRNA-Seq) data. A number of
+computational methods, often referred to as pseudo-time ordering, have been
+developed for this task. CRISPR has also been used to reconstruct lineage
+trees by inserting random mutations. The tbsp package implements an
+alternative method to detect significant, cell type specific sequence
+mutations from scRNA-Seq data.")
+ (license license:expat))))