summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-23 22:50:07 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-23 22:50:07 +0100
commit3cb61ca85a634db2dcc2badaf3492440bf621d92 (patch)
tree72561a5f7056aa29cec7d50fb8b960b32b44a585 /gnu/packages/bioinformatics.scm
parenta60370727a77d1658307698276239c153d8279e8 (diff)
parentf92854fea150f0d47c4984f87bf21bd5f8051820 (diff)
downloadpatches-3cb61ca85a634db2dcc2badaf3492440bf621d92.tar
patches-3cb61ca85a634db2dcc2badaf3492440bf621d92.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ccb49cac9e..1836939970 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6347,6 +6347,28 @@ sequences.")
;; STAR is licensed under GPLv3 or later; htslib is MIT-licensed.
(license license:gpl3+)))
+(define-public starlong
+ (package (inherit star)
+ (name "starlong")
+ (arguments
+ (substitute-keyword-arguments (package-arguments star)
+ ((#:make-flags flags)
+ `(list "STARlong"))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ ;; Allow extra long sequence reads.
+ (add-after 'unpack 'make-extra-long
+ (lambda _
+ (substitute* "source/IncludeDefine.h"
+ (("(#define DEF_readNameLengthMax ).*" _ match)
+ (string-append match "900000\n")))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
+ (install-file "STARlong" bin))
+ #t))))))))
+
(define-public subread
(package
(name "subread")