summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-01 15:53:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-01 15:53:17 +0200
commit4214066d45ec7030405577f225a9db0be04da1fd (patch)
tree2a0d3b6fd454b04721775a2d6846138658cc61ab /gnu/packages/bioinformatics.scm
parent07ca7165f90079948e7174468b47ecc7cd38531d (diff)
parentae66fdaf9f7971c0a1b33d0c20844e903ccd909c (diff)
downloadpatches-4214066d45ec7030405577f225a9db0be04da1fd.tar
patches-4214066d45ec7030405577f225a9db0be04da1fd.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm68
1 files changed, 44 insertions, 24 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 73cca16717..849225bd78 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -767,6 +767,29 @@ into separate processes; and more.")
(define-public python2-biopython
(package-with-python2 python-biopython))
+(define-public python-fastalite
+ (package
+ (name "python-fastalite")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fastalite" version))
+ (sha256
+ (base32
+ "1qli6pxp77i9xn2wfciq2zaxhl82bdxb33cpzqzj1z25yd036wqj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; Test data is not distributed.
+ (home-page "https://github.com/nhoffman/fastalite")
+ (synopsis "Simplest possible FASTA parser")
+ (description "This library implements a FASTA and a FASTQ parser without
+relying on a complex dependency tree.")
+ (license license:expat)))
+
+(define-public python2-fastalite
+ (package-with-python2 python-fastalite))
+
(define-public bpp-core
;; The last release was in 2014 and the recommended way to install from source
;; is to clone the git repository, so we do this.
@@ -1948,15 +1971,18 @@ accessing bigWig files.")
(define-public python-dendropy
(package
(name "python-dendropy")
- (version "4.2.0")
+ (version "4.4.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "DendroPy" version))
+ ;; Source from GitHub so that tests are included.
+ (uri
+ (string-append "https://github.com/jeetsukumaran/DendroPy/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "15c7s3d5gf19ljsxvq5advaa752wfi7pwrdjyhzmg85hccyvp47p"))
- (patches (search-patches "python-dendropy-fix-tests.patch"))))
+ "0v2fccny5xjaah546bsch1mw4kh61qq5frz2ibllxs9mp6ih9bsn"))))
(build-system python-build-system)
(home-page "http://packages.python.org/DendroPy/")
(synopsis "Library for phylogenetics and phylogenetic computing")
@@ -1964,23 +1990,10 @@ accessing bigWig files.")
"DendroPy is a library for phylogenetics and phylogenetic computing: reading,
writing, simulation, processing and manipulation of phylogenetic
trees (phylogenies) and characters.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-dendropy))))))
+ (license license:bsd-3)))
(define-public python2-dendropy
- (let ((base (package-with-python2 (strip-python2-variant python-dendropy))))
- (package
- (inherit base)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- ;; There is currently a test failure that only happens on some
- ;; systems, and only using "setup.py test"
- (lambda _ (zero? (system* "nosetests")))))))
- (native-inputs `(("python2-nose" ,python2-nose)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-dendropy))
(define-public python-py2bit
(package
@@ -6046,7 +6059,13 @@ Cuffdiff or Ballgown programs.")
`(("python-sqlalchemy" ,python2-sqlalchemy)
("python-decorator" ,python2-decorator)
("python-biopython" ,python2-biopython)
- ("python-pandas" ,python2-pandas)))
+ ("python-pandas" ,python2-pandas)
+ ("python-psycopg2" ,python2-psycopg2)
+ ("python-fastalite" ,python2-fastalite)
+ ("python-pyyaml" ,python2-pyyaml)
+ ("python-six" ,python2-six)
+ ("python-jinja2" ,python2-jinja2)
+ ("python-dendropy" ,python2-dendropy)))
(home-page "https://github.com/fhcrc/taxtastic")
(synopsis "Tools for taxonomic naming and annotation")
(description
@@ -12833,11 +12852,12 @@ once. This package provides tools to perform Drop-seq analyses.")
(lambda _
(substitute* "Makefile.in"
(("(^ tests/test_trim_galore/test.sh).*" _ m) m)
+ (("^ tests/test_multiqc/test.sh") "")
(("^ test.sh") ""))
#t)))))
(inputs
`(("gzip" ,gzip)
- ("snakemake" ,snakemake)
+ ("snakemake" ,snakemake-4)
("fastqc" ,fastqc)
("multiqc" ,multiqc)
("star" ,star)
@@ -12931,7 +12951,7 @@ expression report comparing samples in an easily configurable manner.")
("fastqc" ,fastqc)
("bowtie" ,bowtie)
("idr" ,idr)
- ("snakemake" ,snakemake)
+ ("snakemake" ,snakemake-4)
("samtools" ,samtools)
("bedtools" ,bedtools)
("kentutils" ,kentutils)))
@@ -12992,7 +13012,7 @@ in an easily configurable manner.")
("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc-with-pandoc-1)
("python-wrapper" ,python-wrapper)
("python-pyyaml" ,python-pyyaml)
- ("snakemake" ,snakemake)
+ ("snakemake" ,snakemake-4)
("bismark" ,bismark)
("fastqc" ,fastqc)
("bowtie" ,bowtie)
@@ -13041,7 +13061,7 @@ methylation and segmentation.")
("python-loompy" ,python-loompy)
("ghc-pandoc" ,ghc-pandoc-1)
("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc-with-pandoc-1)
- ("snakemake" ,snakemake)
+ ("snakemake" ,snakemake-4)
("star" ,star)
("r-minimal" ,r-minimal)
("r-argparser" ,r-argparser)