summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-13 12:55:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-13 13:04:18 +0100
commit7097c7009deae1a1b4997e5222fd72b0c6c330f4 (patch)
tree065b31f22380ed0f9d151a5e4818e22c8e6f0c4a /gnu/packages/bioconductor.scm
parentc80fb90f4a04deca33ef7e7b92d4678ca5ef93af (diff)
downloadpatches-7097c7009deae1a1b4997e5222fd72b0c6c330f4.tar
patches-7097c7009deae1a1b4997e5222fd72b0c6c330f4.tar.gz
gnu: r-annotate: Move to bioconductor.
* gnu/packages/bioinformatics.scm (r-annotate): Move from here... * gnu/packages/bioconductor.scm (r-annotate): ...to here.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 37ac94128b..22d8b5320b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017, 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -228,6 +228,33 @@ database is exposed as a @code{TxDb} object.")
(license license:artistic2.0)))
+(define-public r-annotate
+ (package
+ (name "r-annotate")
+ (version "1.60.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "annotate" version))
+ (sha256
+ (base32
+ "0p6c96lay23a67dyirgnwzm2yw22m592z780vy6p4nqwla8ha18n"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-dbi" ,r-dbi)
+ ("r-rcurl" ,r-rcurl)
+ ("r-xml" ,r-xml)
+ ("r-xtable" ,r-xtable)))
+ (home-page
+ "https://bioconductor.org/packages/annotate")
+ (synopsis "Annotation for microarrays")
+ (description "This package provides R environments for the annotation of
+microarrays.")
+ (license license:artistic2.0)))
+
(define-public r-hpar
(package
(name "r-hpar")