summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-18 15:25:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-18 15:29:08 +0100
commit4d12c1e335e3949c451b045a1f128200432fdde9 (patch)
tree7422a2c6b5f4a81d68d9bec382713cdd64886713 /gnu/packages/bioconductor.scm
parentc2b36a044140a2f1a186b85002e5c8ed98163a25 (diff)
downloadpatches-4d12c1e335e3949c451b045a1f128200432fdde9.tar
patches-4d12c1e335e3949c451b045a1f128200432fdde9.tar.gz
gnu: Add r-biocor.
* gnu/packages/bioconductor.scm (r-biocor): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2bc453dcaa..62ec80397c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7247,3 +7247,30 @@ rownames.")
"The purpose of this package is to provide a central interface to various
tools for genome-scale analysis of cancer studies.")
(license license:artistic2.0)))
+
+(define-public r-biocor
+ (package
+ (name "r-biocor")
+ (version "1.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BioCor" version))
+ (sha256
+ (base32
+ "1bjw02rwmz2d715sgpfp08njb15200ch7cmipsf9hd5835ppg1jl"))))
+ (properties `((upstream-name . "BioCor")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocparallel" ,r-biocparallel)
+ ("r-gseabase" ,r-gseabase)
+ ("r-matrix" ,r-matrix)))
+ (home-page "https://llrs.github.io/BioCor/")
+ (synopsis "Functional similarities")
+ (description
+ "This package provides tools to calculate functional similarities based
+on the pathways described on KEGG and REACTOME or in gene sets. These
+similarities can be calculated for pathways or gene sets, genes, or clusters
+and combined with other similarities. They can be used to improve networks,
+gene selection, testing relationships, and so on.")
+ (license license:expat)))