summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-18 15:25:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-18 15:29:08 +0100
commit0156297f2920a036a7060586ea3286ed5ecbab26 (patch)
tree8cf357c75474f0aef0f935f2f7fad6be2a749419 /gnu/packages/bioconductor.scm
parent43b66e3f7c7628804faf0f336c903458d319f412 (diff)
downloadpatches-0156297f2920a036a7060586ea3286ed5ecbab26.tar
patches-0156297f2920a036a7060586ea3286ed5ecbab26.tar.gz
gnu: Add r-biocworkflowtools.
* gnu/packages/bioconductor.scm (r-biocworkflowtools): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 8bd6bfe7af..7d45a26579 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7351,3 +7351,34 @@ The user has the abilty to activate one of these three tibbles to perform
common functions from the @code{dplyr} package. Mapping functionality and
accessing web references for elements/sets are also available in BiocSet.")
(license license:artistic2.0)))
+
+(define-public r-biocworkflowtools
+ (package
+ (name "r-biocworkflowtools")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiocWorkflowTools" version))
+ (sha256
+ (base32
+ "1v4bhnpdkmllm7aghms9b7369hkrgz7mn69wbrqg1x42pgkf30ad"))))
+ (properties
+ `((upstream-name . "BiocWorkflowTools")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocstyle" ,r-biocstyle)
+ ("r-bookdown" ,r-bookdown)
+ ("r-git2r" ,r-git2r)
+ ("r-httr" ,r-httr)
+ ("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-stringr" ,r-stringr)
+ ("r-usethis" ,r-usethis)))
+ (home-page "https://bioconductor.org/packages/BiocWorkflowTools/")
+ (synopsis "Tools to aid the development of Bioconductor Workflow packages")
+ (description
+ "This package provides functions to ease the transition between
+Rmarkdown and LaTeX documents when authoring a Bioconductor Workflow.")
+ (license license:expat)))