summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-31 14:40:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-31 14:40:20 +0200
commit81e3de01ae2ac0e9cedc5625d25fd9b3d31e07fa (patch)
treef54c145a97cef12b7a70fa617a02dd4e984e3db2 /gnu/packages/bioconductor.scm
parent95bf71c307cbc9c4d1380d5b82448db55be5afe1 (diff)
downloadpatches-81e3de01ae2ac0e9cedc5625d25fd9b3d31e07fa.tar
patches-81e3de01ae2ac0e9cedc5625d25fd9b3d31e07fa.tar.gz
gnu: Add r-birewire.
* gnu/packages/bioconductor.scm (r-birewire): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e38d796a9..10a4079fea 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4548,3 +4548,32 @@ high-throughput sequencing data. It performs parallel processing of entire
files and produces a report which contains a set of high-resolution
graphics.")
(license license:gpl2+)))
+
+(define-public r-birewire
+ (package
+ (name "r-birewire")
+ (version "3.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiRewire" version))
+ (sha256
+ (base32
+ "1gjb18l3gq3w8zl6r5d49hw0r1kfh9f7ghv9hz6y86aniprvb518"))))
+ (properties `((upstream-name . "BiRewire")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-igraph" ,r-igraph)
+ ("r-matrix" ,r-matrix)
+ ("r-slam" ,r-slam)
+ ("r-tsne" ,r-tsne)))
+ (home-page "https://bioconductor.org/packages/release/bioc/html/BiRewire.html")
+ (synopsis "Tools for randomization of bipartite graphs")
+ (description
+ "This package provides functions for bipartite network rewiring through N
+consecutive switching steps and for the computation of the minimal number of
+switching steps to be performed in order to maximise the dissimilarity with
+respect to the original network. It includes functions for the analysis of
+the introduced randomness across the switching steps and several other
+routines to analyse the resulting networks and their natural projections.")
+ (license license:gpl3)))